Monday, July 19, 2010

 

Sunset or Eclipse with Oracle JVM

When you run the new Oracle JVM 6u21 and Eclipse you may encounter frequent Eclipse crashes.

Eclipse launcher (which is written in C/C++) reads the JVM vendor and if it detects a Sun JVM, it adds a necessary memory parameter for Eclipse to function.
Since now the "Java" vendor was changed from Sun to Oracle it crashes.

So the current version of Eclipse does not work with the current version of Java on the most popular platform - at least not out of the box.

There is a bug report already ...

Comments:
I am looking forward for the day when they change all the package names starting with com.sun.* to com.oracle.* ... ;-)
 
Post a Comment

<< Home

This page is powered by Blogger. Isn't yours?